Tuesday, March 8, 2011

Blender 2.5 Compile Errors

Hi, Blenderheads! I need you help. Just a few hours ago, before firing up Blender 2.5 in Linux, I updated it via SVN by compiling using Scons. Please pardon me for my ignorance on such technical stuff, I just really couldn't get my way out of this.

Yesterday, after running the same build commands (which I compressed into one batch file), everything went smoothly and Blender 2.5 was successfully built (as I would have expected after almost 6 months of doing so). Then this problem came up this morning.

I have Python 3.1 installed and so I wondered why I was prompted that I needed to update my Python.

I am still able to execute Blender 2.5 but then I'm presented with this headerless set of windows (except for the Properties window) plus some other annoying things like non-responsiveness of the 3d viewport shading (wire, shaded, etc.).

By the way, Build instructions are similar to one seen on this page > http://wiki.blender.org/index.php/Dev:2.5/Doc/Building_Blender/Linux/Ubuntu/Scons

Anyhow, I'm hoping you guys could help me on this. Thank you so much in advance!

Below you can see screenshots of the error I have been mentioning (click thumbnails to enlarge).


Sergof said...

The error message itself has an error in it unfortunately.
You need Python 3.2 to build blender now.
It might look harsh at first but I encourage you to read through this thread on the mailing list: http://lists.blender.org/pipermail/bf-committers/2011-March/030757.html
You should be able to find some tips on how to handle the problem in some of the replies (among other frustrated users).
In short: you need to install (or compile) python 3.2 and setup your build system to find it (in your case editing user-config.py).

Dalai Felinto said...

yesterday Blender officially did a change from Python 3.1 to Python 3.2.

There has been some discussions and post commit troubleshooting in the mailing-list (bf-committers). But simply put try to update your system to Python 3.2 and it should all work.

I hope that helps ;)

Floft said...

You might want to try upgrading to Python 3.2 (or at least installing it somewhere and building with it). I'm not sure what "PY_VERSION_HEX < 0x03020000" requires... but there's a 3 and a 2 in it. =) I use http://aur.archlinux.org/packages/blender-svn/PKGBUILD to build it. I just updated it again to verify it actually works here; it does.

reynante said...

Thanks, Sergof. I should have paid attention to campbell's SVN commit.

I'll now apply all necessary changes needed.


reynante said...

Dalai: Yes, I think that's what I should do. Thanks. I"ll update you whenever I can. Wish me luck!

reynante said...

Floft: Thanks, pal. That's very very helpful.